Requires Downflow Kit

Kit is required when installed in a downflow application.